How to fix Exchange "Insufficient system resources"

Created by Abderrahim Ibnou el kadi, Modified on Fri, 28 May 2021 at 08:51 AM by Abderrahim Ibnou el kadi

Symptoms:


The mail server "Exchange server" is not receiving any Inbound mail and the mail server trying to send is getting this error "4.3.1 insufficient system resources"


Cause:


The Back pressure feature is part of Microsoft Exchange Transport service that exists on mailbox server(s) and Edge Transport server(s).

the Back pressure monitors the system resource such as hard drive space, memory if they are overloaded then takes actions 

Back pressure checks all required resources and ensures that all of them are in consistent state and ready to overcome the condition of Exchange server overwhelmed and unavailable.

The below is that the resources that the back pressure monitors prior to establishing a new connection: 

  • DatabaseUsedSpace[%ExchangeInstallPath%TransportRoles\data\Queue]: Hard drive utilization for the drive that holds the message queue database
  • PrivateBytes: The memory that’s used by the EdgeTransport.exe process.
  • QueueLength[SubmissionQueue]: The number of messages in the Submission queue.
  • SystemMemory: The memory that’s used by all other processes.
  • UsedDiskSpace[%ExchangeInstallPath%TransportRoles\data\Queue]: Hard drive utilization for the drive that holds the message queue database transaction logs.
  • UsedDiskSpace[%ExchangeInstallPath%TransportRoles\data]: Hard drive utilization for the drive that’s used for content conversion.
  • UsedVersionBuckets [%ExchangeInstallPath%TransportRoles\data\Queue\mail.que]: The number of uncommitted message queue database transactions that exist in memory.

 if there is a lack or resources then it denies the connections to protect the server from overloading of the transport service and ALL incoming mail get rejected with "4.3.1 insufficient system resources"

The only way to fix this is to bring back the system resources to a Normal level.


Solution:


to resolve this issue you can execute the below commands on your exchange server

[PS] C:\Windows\system32>Get-TransportServer “servername” | fl

Make sure that “PipelineTracingEnabled = False”

If not then disable it by running the following command:

Set-TransportService Mailbox01 -PipelineTracingEnabled $false

Then Run,

[PS] C:\Windows\system32>Get-TransportConfig

Make sure that MaxDumpsterSizePerDatabase = 18 MB (18,874,368 bytes)

It should always be in MBs only.

Then check Queue:

[PS] C:\Windows\system32>Get-Queue

MessageCount = 0

Then stop Microsoft Exchange Transport Service.


Note: to get detailed information from  Microsoft please refer to this document <click here>